Logo Hardware.com.br
Daniel_Araujo
Daniel_Arauj... Novo Membro Registrado
12 Mensagens 0 Curtidas

[Resolvido] Excel - Somar SE com critério data - usando o endereço (célula) da data na fórmula

#1 Por Daniel_Arauj... 02/09/2020 - 13:17
Boa tarde!

Estou criando uma planilha de controle de gastos, que usa os meses como base de calculo, porém, a única maneira que sei fazer, é a formula que usa, exemplo, valor entre ">=01/01/2020" e "<=01/02/2020", porém, escrever data por data dentro da formula, seria muito trabalhoso, e inviável para relatórios extensos. O que gostaria de fazer é utilizar o endereço da data como critério, exemplo, valor maior que G3 (onde G3 contém a data 01/01/2020) e menor que G4 (onde G4 contém a data 01/02/2020). Procurei aqui e em outros lugares, porém, sem sucesso poderiam me ajudar?

Segue planilha, para facilitar o entendimento.

Desde já, agradeço a ajuda.

Anexos

EdsonBR
EdsonBR Veterano Registrado
274 Mensagens 280 Curtidas
#2 Por EdsonBR
02/09/2020 - 13:37
Olá, @Daniel_Araujo
Fórmula em H3 e arraste - opção com SOMASES:
=SOMASES($D$2:$D$7;$A$2:$A$7;">="&G3;$A$2:$A$7;"<="& FIMMÊS(G3;0))


Fórmula em H3 e arraste - opção com SOMARPRODUTO:
=SOMARPRODUTO((MÊS($A$2:$A$7)=MÊS(G3))*(ANO($A$2:$A$7)=ANO(G3))*$C$2:$C$7*$D$2:$D$7)


ATENÇÃO!.A primeira opção não multiplica a coluna da quantidade pelo valor unitário (soma só os preços unit.) pois a fórmula SOMASES aceita só intervalo como argumento e não uma matriz ou operação sobre um intervalo. Vc teria então que criar uma coluna a mais com gasto total e usá-la no lugar do intervalo $D$2:$D$7. A segunda opção multiplica quantidade por preço unitário e dá o resultado corretamente. Vc só irá perceber a diferença em sua planilha se alterar alguns dos itens já que todos têm quantidade =1 para outro valor.
© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal