Logo Hardware.com.br
Deutriex
Deutriex Geek Registrado
2.1K Mensagens 206 Curtidas

[Resolvido] Máquina virtual não incia após atualização do VirtualBox

#1 Por Deutriex 24/01/2023 - 23:41
Uso o Ubuntu 22.10. O Secure Boot está desativado. Tinha o VirtualBox 6.1 instaldo e tudo funcionava corretamente. Quando tive a brilhante ideia de atualizar para o VirtualBox 7.0, as máquinas virtuais que criei pararam de funcionar. Agora toda a vez que tento iniciar qualquer máquina virtual dá esse erro:
Anexo do post

Já tentei rodar o comando sugerido, mas toda a vez que rodo dá o erro da tela abaixo:
Anexo do post
Quando tento rodar o comando modprobe vboxnetadp, recebo a seguinte mensagem:
modprobe: ERROR: could not insert 'vboxnetadp': Invalid argument.

Já pesquisei na Internet, já pesquisei no YouTube e nada, não sei mais o que fazer...

Anexos

TRONNER
TRONNER Cyber Highlander Registrado
32.2K Mensagens 7.3K Curtidas
#4 Por TRONNER
28/01/2023 - 19:26
Mas você removeu com o -p ou só mandou instalar por cima ?!
Linux é chato pra esses bagui, mesmo assim já estamos na versão 7.0.6, penso que seria melhor remover a atual para depois instalar a mais recente, depois mandar um apt-get autoclean e depois um apt-get autoremove para eliminar arquivos desnecessários, por último um sudo apt upgrade para subir tudo o que precisar ser atualizado, daí tentar novamente o Virtual Box.
cool.png**Quando pensar ser um Golias, cuidado para não encontrar algum Davi**
veja.png Conheça os Poderosos e Gratuitos [ Iperius Backup ] e [ Iperius Remote ]
veja.png Todo dia um software novo e grátis [ clicando aqui ]
boa.gif Faça valer a sua voz com o Mudamos+ { https://www.mudamos.org }
Deutriex
Deutriex Geek Registrado
2.1K Mensagens 206 Curtidas
#5 Por Deutriex
07/02/2023 - 00:14
Resolvi aqui: Reinstalei o VirtualBox 6.1 pela Ubuntu Store e minhas máquinas virtuais voltaram a funcionar. Os executáveis do site da Oracle não funciona, seja a versão 7.0 ou a versão 6.1.
Note "APOLLO11": Sony 4k 65'' | Notebook Gamer NAVE Polaris GK5NP50 - 120hz | AMD Ryzen 4600H | NVIDIA GeForce GTX 1650 Mobile | Kingston NV1 2TB | 64GB DDR4 3200 MHz
TRONNER
TRONNER Cyber Highlander Registrado
32.2K Mensagens 7.3K Curtidas
#6 Por TRONNER
07/02/2023 - 14:07
Deutriex disse:

Já precisei ficar na versão 4.x quando o Windows 10 foi lançado pois dava erro de instalação na recém-lançada versão 5.0, entendo como se sente legal.png
cool.png**Quando pensar ser um Golias, cuidado para não encontrar algum Davi**
veja.png Conheça os Poderosos e Gratuitos [ Iperius Backup ] e [ Iperius Remote ]
veja.png Todo dia um software novo e grátis [ clicando aqui ]
boa.gif Faça valer a sua voz com o Mudamos+ { https://www.mudamos.org }
andremachado
andremachado Highlander Registrado
3.3K Mensagens 2K Curtidas
#7 Por andremachado
07/02/2023 - 14:26
@Deutriex

Realmente frustrante sua situação. No entanto, é fato conhecido que, quando se atualiza a versão do VirtualBox, é necessário recompilar o seu módulo do kernel. Para isso, é necessário, dentre outras coisas, ter os fontes do kernel e suas ferramentas de construção devidamente instaladas no sistema hospedeiro.
56 6F 63 EA 20 E9 20 6D 75 69 74 6F 20 63 75 72 69 6F 73 6F 2E 2E 2E
----------------------------------------
Acer Aspire E5-471-30DG (Casa)
Samsung Book 550XDA-K07 (Trabalho)
© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal