Logo Hardware.com.br
jgama
jgama Ubbergeek Registrado
7.2K Mensagens 66 Curtidas

Sofrendo com as configurações do squid

#1 Por jgama 30/05/2004 - 13:16
Pessoal, estou determinado a de uma vez por toda acabar com a novela do Squid.

Uso Slack 9.1

Ontem estava fazendo uns testes, para verificar se conseguia fazer as estações logar na internet através do squid, mas até o momento não está dando certo.

Como eu escolhir autenticação atraves do Samba coloquei estas linhas no arquivo do squid.conf

auth_param basic program /usr/local/bin/smb_auth -W LINUX -U 192.168.0.1
auth_param basic children 5
auth_param basic realm Digite seu Login (nesta linha é necessário deixa desta forma?)
auth_param basic credentialsttl 2 hours

No Servidor o Squid esta rodando sem erros,

11:45:55root@serv1linux/home/valdir#/usr/local/squid/sbin/squid -D
11:45:55root@serv1linux/home/valdir#


Estava seguindo também um tuto onde dava uma dicas como deixa o squid via nat transparente.

http://www.vivaolinux.com.br/artigos/verArtigo.php?codigo=381


Depois que incluir as linhas indicadas no tuto, aparece estas mensagens:

12:49:46root@serv1linux/usr/local/squid#./RunCache &
[1] 25565
bash: ./RunCache: No such file or directory
[1]+ Exit 127 ./RunCache
ocal/squidot@serv1linux/usr/local/squid#


Descupa por ter tantas dúvidas, segue mais uma:

No firewall tem uma linha para direcionar o squid, mas como uso Sppedy qual seria a linha correta?

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to 3128
iptables -t nat -A PREROUTING -i ppp0 -p tcp --dport 80 -j REDIRECT --to 3128

ppp0 = Internet via speedy
eth0 = placa de rede local
eth1 = placa de rede com a conexão do modem da speedy.

Bom alguém com saco para ajudar nestes problemas.

Conto com a colaboração.

Abraço
© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal