Logo Hardware.com.br
zaurus
zaurus Membro Junior Registrado
60 Mensagens 0 Curtidas

[Resolvido] Não consigo instalar o Qtbittorrent no Mandriva

#1 Por zaurus 30/11/2010 - 00:49
Tenho um desktop com o Ubuntu 10.10 e Qtbittorrent rodando os dois felizes, fazendo meus olhos brilharemdance.gif Mas no meu outro desktop tenho o Mandriva 2010 Spring e até agora nada de rodar o Qtbittorrent. Alguem sabe uma maneira fácil de instalar o programa? Estou aprendendo a mexer no Mandriva, resolvi adotá-lo e estou tendo a maior paciência do mundo com ele. No repositório não aparece o QBit (leia-se Qbittorrent) pra instalar. Então fui no site e baixei-o. Está no formato tar.gz. Ok, descompactei-o numa pasta. Li a instrução de instalação contida no arquivo e diz:

1) Compile and install qBittorrent with Qt4 Graphical Interface

$ ./configure
$ make && make install
$ qbittorrent


Quando executo o 1° comando aparece a mensagem que me estarreceu:

[root@localhost qbittorrent-2.4.11]# ./configure
Configuring qbittorrent ...
Verifying Qt 4 build environment ... fail

Reason: There was an error compiling 'conf'. See conf.log for details.

Be sure you have a proper Qt 4.0 build environment set up. This means not
just Qt, but also a C++ compiler, a make tool, and any other packages
necessary for compiling C++ programs.

If you are certain everything is installed, then it could be that Qt 4 is not
being recognized or that a different version of Qt is being detected by
mistake (for example, this could happen if $QTDIR is pointing to a Qt 3
installation). At least one of the following conditions must be satisfied:

1) --qtdir is set to the location of Qt
2) $QTDIR is set to the location of Qt
3) QtCore is in the pkg-config database
4) qmake is in the $PATH

This script will use the first one it finds to be true, checked in the above
order. #3 and #4 are the recommended options. #1 and #2 are mainly for
overriding the system configuration.


Instalei o Qt4 creator e Qt4 designer, mas ainda assim aparece a mensagem de ...fail!bravo.png
Como posso saber se as 4 condições estão corretas?fiquei_triste.png

1) --qtdir is set to the location of Qt
2) $QTDIR is set to the location of Qt
3) QtCore is in the pkg-config database
4) qmake is in the $PATH
Ilkyest
Ilkyest Super Zumbi Registrado
5.8K Mensagens 715 Curtidas
#4 Por Ilkyest
30/11/2010 - 09:29
abre o olho que o qbittorrent tem duas instalacoes a fazer. nao eh apenas ele, tem ele e outro. infelizmente nao lembro o nome agora (daaaaa..... grande ajuda)

mas tambem tentei instalar diretamente e nada feito. se nao me falha a memoria eh o libtorrent-rasterball (nome parecido, verificar) e o qbittorrent
ASUS 1151 ATX PRIME Z270-K/ Intel i7 7700k / 16Gb Kingston HyperX FURY 2133Mhz DDR4 /Radeon RX570 Powercolor 4Gb // Corsair TX 750W modular // Air Cooler Stock
deusdara
deusdara Tô em todas Registrado
1.8K Mensagens 70 Curtidas
#5 Por deusdara
30/11/2010 - 10:46
Olá

No link que coloquei na minha mensagem anterior tem o seguinte:

Stable (on Sourceforge)

qBittorrent and libtorrent sources are available on sourceforge:
O link é este na versão para Mandriva

http://qbittorrent.sourceforge.net/download.php

Abraços

Deusdará
[Mobo: Asus B85M-E/BR ][CPU: Intel Core i7 4790@3.6 GHz][RAM2x4 GB 1333 MHz DDR3 Kingston][GPU: nVidia GTX 570][HD:Seagate 1,0 TB SATA II][Fonte: Corsair CX 750 W ][Sabayon Gnome]
zaurus
zaurus Membro Junior Registrado
60 Mensagens 0 Curtidas
#6 Por zaurus
30/11/2010 - 13:55
Jose Monteiro disse:
Pelo que li ele está nos repositórios oficiais. Tentou o comando urpmi qbittorrent ?


Cara não acredito!! Funcionou esse comando!punk.gif Mas não pode, eu tentei todos os comandos possíveis, acho que até esse urpmi. Só que não sei se é isso, mas eu puxei esse comando dentro da pasta onde está o Qbit. Talvez isso seria ou é o obvio pra fazer funcionar. Mas eu estava bloqueado e não pensava mais. Funcionou de primeira. Valeu galera, obrigado pela ajuda. Está ficando bomfeliz.png
apimente.br
apimente.br Cyber Highlander Moderador
51.3K Mensagens 3.8K Curtidas
#7 Por apimente.br
30/11/2010 - 22:15
Embora esteja resolvido:

"apimente.br"
O Mandriva tem ferramentas que facilitam (e muito) a instalação de pacotes.
O uso de pacotes que não foram preparados especialmente para o Mandriva pode provocar sérios danos à instalação.
Você deve configurar (se ainda não fez) as fontes de pacotes. Veja neste artigo como fazer isso:
http://www.mandrivabrasil.org/site/content/view/13/29/
Seguindo as dicas do artigo e configurando as fontes de pacotes você não terá problemas para instalar pacotes no Mandriva. Em pouco tempo estará elogiando a ferramenta de instalação de pacotes do Mandriva.
Se preferir pode fazer pelo Mandrake Control Center:
Menu -> System -> Configuration -> Configure your Computer
Escolha Software Packages Instalation e então selecione o pacote que deseja. A ferramenta se encarregará de escolher o pacote mais atualizado e todas as dependências (se houver).
O Linux não é o Windows
Como fazer perguntas inteligentes? Clique aqui!
Ao pedir ajuda, informe sua configuração completa e forneça detalhes suficientes para alguém te ajudar.

© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal