Logo Hardware.com.br
aeav
aeav Veterano Registrado
1.2K Mensagens 5 Curtidas

Erro ao instalar o Glib

#1 Por aeav 05/05/2003 - 19:03
Estou utilizando o Slackware e quero instalar o GTK, mas para isso preciso instalar o Glib.
Tudo certo até então, dei o comando "./configure"

E apareceu o seguinte erro:

configure: error: *** pkg-config too old; version 0.14 or better required


Como resolver este problema?


Grato! big_green.png
Xterminator-again
Xterminator-... Tô em todas Registrado
2.5K Mensagens 2 Curtidas
#2 Por Xterminator-...
05/05/2003 - 23:32
Simples qual versão do Slackware ?
pois o Slackware 8.1 usa o pkgconfig-0.12...
descubra qual versão está instalada....
ls /var/log/packages/pkg[TAB][TAB]
e atualize asta baixá-lo de.
ftp://ftp.gnome.org/pub/gnome/sources/pkgconfig/

A versão mais atual é 0.15
aproveita e já verifica se você tem o atk também.
ftp://ftp.gnome.org/pub/gnome/sources/atk/

Qualquer dependência basta pegar aqui.
ftp://ftp.gnome.org/pub/gnome/sources/

veja bem leve em conta que existem umas pré-dependências requeridas pra compilar glib2 que você deve verificar se você já tem instalado.

libpng3
libjpeg
libtiff
XFree86---Principlamente xmkmf para poder compilar o fcpackage que inclui fontconfig,Xrender
libbz2
zlib
expat
docbook
libxml
libxslt
freetype2

e outras que eu não me lembro agora sendo que a maioria delas está disponível no CD ou já estão instaladas, mas provavelmente algumas você tera que atualizar.
dá uma procurada aqui no fórum por little gnome installation guide.
© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal