Logo Hardware.com.br
ThOR27
ThOR27 Super Participante Registrado
568 Mensagens 0 Curtidas

Debian não reconhece meu pendriver

#1 Por ThOR27 12/08/2005 - 15:12
Já testei em outras distribuições e meu pendriver sempre funcionou perfeitamente.

No debian, em 7 máquinas diferente meu pendriver não funciona.

mp067228:/etc# mount /dev/sda1 /mnt/
mount: você precisa especificar o tipo do sistema de arquivos
mp067228:/etc# mount /dev/sda1 /mnt/ -t vfat
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

mp067228:/etc# dmesg | tail
Buffer I/O error on device sda1, logical block 508378393
Buffer I/O error on device sda1, logical block 508378394
Buffer I/O error on device sda1, logical block 508378395
Buffer I/O error on device sda1, logical block 508378396
Buffer I/O error on device sda1, logical block 508378397
Buffer I/O error on device sda1, logical block 508378398
Buffer I/O error on device sda1, logical block 508378399
Buffer I/O error on device sda1, logical block 508378384
FAT: invalid media value (0xb9)
VFS: Can't find a valid FAT filesystem on dev sda1.


em qualquer outra distro, Ubuntu, Mandriva, Slackware, Fedora (das que eu testei) meu pendriver funciona prfeitamente.

Vale lembrar que mesmo no debian o pen driver de um amigo funciona perfeitamente (com o mesmo comando: mount /dev/sda1 /mnt/)


Alguma idéia?
zast
zast Tô em todas Registrado
2K Mensagens 8 Curtidas
#2 Por zast
12/08/2005 - 15:23
ThOR27,

Só para constar, é Pendrive e não Pendriver, ok! Não se ofenda! Mas quanto ao seu problema você errou no comando, veja como deve ficar:

mp067228:/etc# mount /dev/sda1 /mnt/usb ou pendrive, mas acho que é usb mesmo. Tente aí.


Lembre-se que tem que criar esta pasta /usb dentro do /mnt,

Consulte aí no konqueror também:

devices:/

Abraços...
Paulo Zambon - aka zast big_green.png

arkRed"> "Põe a semente na terra, não será em vão. Não te preocupe a colheita, plantas para o irmão."
ThOR27
ThOR27 Super Participante Registrado
568 Mensagens 0 Curtidas
#3 Por ThOR27
12/08/2005 - 15:39
Não cara..eu posso montar o dispositivo na pasta que eu quiser..tanto na mnt, quanto na media, quanto dentro da minha home...

e se vc não leu:
Vale lembrar que mesmo no debian o pen driver de um amigo funciona perfeitamente (com o mesmo comando: mount /dev/sda1 /mnt/

agora, só pra não dizer que não tentei:
mp067228:/etc# mkdir /mnt/usb
mp067228:/etc# mount /dev/sda1 /mnt/usb/
mount: você precisa especificar o tipo do sistema de arquivos
mp067228:/etc# mount /dev/sda1 /mnt/usb/ -t vfat
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

mp067228:/etc# dmsg | tail
bash: dmsg: command not found
mp067228:/etc# dmesg | tail
Buffer I/O error on device sda1, logical block 508378395
Buffer I/O error on device sda1, logical block 508378396
Buffer I/O error on device sda1, logical block 508378397
Buffer I/O error on device sda1, logical block 508378398
Buffer I/O error on device sda1, logical block 508378399
Buffer I/O error on device sda1, logical block 508378384
FAT: invalid media value (0xb9)
VFS: Can't find a valid FAT filesystem on dev sda1.
FAT: invalid media value (0xb9)
VFS: Can't find a valid FAT filesystem on dev sda1.



pelo menos sua resposta serviu pra me ensinar como se escreve pendrive.....
PC¹: ASUS K8N / 1GB DDR400 / Sempron 64 3000+ 1.8ghz@2.34Ghz / GF6 6600GT 128MB / Mandriva2006 / Ubuntu 5.10 / BigLINUX 3 beta
PC²: ASUS A7V400-MX SE / Sempron 2600+ / 1GB DDR333 / Mandriva2006
pflynn
pflynn Ubbergeek Registrado
5.5K Mensagens 122 Curtidas
#4 Por pflynn
12/08/2005 - 16:10
Pode ser um bug do kernel em relacão ao pendrive. Ja passei por isso, mais especificamente no kernel 2.6.11, onde não consigo montar o memorystick do meu notebook e nem usar meu adaptador wireless USB. Em outras versões do kernel (anteriores ou posteriores), não tive problema algum.
------------------------------------------------
Muito bom. Mas tijolo não revida!
------------------------------------------------
zast
zast Tô em todas Registrado
2K Mensagens 8 Curtidas
#6 Por zast
12/08/2005 - 16:17
Tem certeza que é o sda1? Não poderia ser o sda2? Faça um teste, espete o pendrive e abra o QTParted ou o GParted aí e tente, acho que o cfdisk também vale. Veja se estes programas reconhecem seu pendrive, depois poste o resultado aqui.
Paulo Zambon - aka zast big_green.png

arkRed"> "Põe a semente na terra, não será em vão. Não te preocupe a colheita, plantas para o irmão."
jqueiroz
jqueiroz Cyber Highlander Registrado
104K Mensagens 5.7K Curtidas
#8 Por jqueiroz
12/08/2005 - 19:12
Interessante. Em meu Conectiva 10 (Kernel 2.6.11 + patches), o dispositivo não é /dev/sda, é algo como /dev/usb/devices/0, mas o importante é que a montagem é totalmente automática, tanto na instalação quanto na retirada do dispositivo.

Já experimentou olhar pra ver se isso não acontece no seu Debian tb??? De repente vc está tentando montar o que já foi montado...
"chmod 777 nunca ajudou ninguém" (c) 2002-2021 JQueiroz/FGdH
Conheça o Blog do Zekke
ThOR27
ThOR27 Super Participante Registrado
568 Mensagens 0 Curtidas
#9 Por ThOR27
12/08/2005 - 21:14
Não. O Debian não faz isso. É inclusive esta característica que estou desegnado a colocar no debian.

Vou tentar atualizar o Kernel para o 2.6.10 ou mais recente, atualizar o kde para o 3.4.2, usar o supermount nos disquetes, desbloquear cd quando montado.

essas coisas.

[]!
PC¹: ASUS K8N / 1GB DDR400 / Sempron 64 3000+ 1.8ghz@2.34Ghz / GF6 6600GT 128MB / Mandriva2006 / Ubuntu 5.10 / BigLINUX 3 beta
PC²: ASUS A7V400-MX SE / Sempron 2600+ / 1GB DDR333 / Mandriva2006
Areia
Areia Super Participante Registrado
1.5K Mensagens 0 Curtidas
#10 Por Areia
12/08/2005 - 23:06
ThOR27
Não. O Debian não faz isso. É inclusive esta característica que estou desegnado a colocar no debian.

Vou tentar a...


O Debian monta sim os dispositivos USB automaticamente, aqui eu uso o Kernel 2.6.8(padrão quando se instala linux26 no boot), e funciona perfeitamente, inclusive há um tempo atrás, espetei uma câmera fotográfica, e apareceu um ícone no desktop, e todas as fotos estavam lá, e minha mulher disse, pôxa, bem mais fácil que no Windows! big_green.png
T+
ThOR27
ThOR27 Super Participante Registrado
568 Mensagens 0 Curtidas
#11 Por ThOR27
15/08/2005 - 14:39
Ele MONTA apenas se vc atualizar o GNOME, e se atualizar o KDE ele APENAS cria o ícone na tela, mas não MONTA, mesmo com o 3.4.........a não ser que você inicie o gnome-volume-manager na inicialização do KDE. Apenas o KDE3.5 que trará um recurso similar ao gnome-volume-manager.

E o meu problema não é mostrar o dispositivo, é MONTAR o dispositivo.

ele CRIA o /dev/sda1

mas ele não MONTA

da os erros acima citado.
e é apenas com alguns pen drives específicos, com outros funciona. E isso só ocorre no debian.


[]!
PC¹: ASUS K8N / 1GB DDR400 / Sempron 64 3000+ 1.8ghz@2.34Ghz / GF6 6600GT 128MB / Mandriva2006 / Ubuntu 5.10 / BigLINUX 3 beta
PC²: ASUS A7V400-MX SE / Sempron 2600+ / 1GB DDR333 / Mandriva2006
© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal