Logo Hardware.com.br
FAdrian Fox
FAdrian Fox Membro Junior Registrado
129 Mensagens 0 Curtidas

Problemas com ATK - GLIB - GTK.

#1 Por FAdrian Fox 06/04/2003 - 21:04
Pessoal, boa noite!!!

Eu dei uma pesquisada no fórum e achei a seguinte informação: para instalar o GTK+, deveria fazer o seguinte caminho:

PKGCONFIG -> ATK -> GLIB -> GTK

Tb foi dito que eu deveria pegar as versões mais atuais das bibliotecas citadas. Bom, foi isso que eu fiz, mas deu merrda!!!

O PKGCONFIG passou direto. Quando fui instalar o ATK, ele deu a seguinte msg:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.0.0, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/.
[FAdrian@localhost atk-1.0.0]$


Busquei e instalei o Glib-2.0.0. Tudo correu bem. Tentei novamente com o ATK e, para a minha surpresaa, recebi a mesma msg.
Só de sacanagem tentei instalar o GTK+ e apareceu isso:

checking for pkg-config... /usr/local/bin/pkg-config
checking for glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1... Requested 'glib-2.0 >= 2.1.4' but version of GLib is 2.0.0

configure: error: Library requirements (glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
[FAdrian@localhost gtk+-2.2.1]$


Ou seja, tomei!!!


Alguém sabe me dizer o que está acontecendo e como posso resolver isso?
Ah, uso o RH 8.

Abcs...
Xterminator-again
Xterminator-... Tô em todas Registrado
2.5K Mensagens 2 Curtidas
#3 Por Xterminator-...
11/04/2003 - 00:27
Só ví essa mesagem agora.....
bem você já compilou a glib ?
veja que ele está pedindo uma versão 2.1.4 ou superior...e está encontrando uma versão antiga.

checking for glib-2.0 >= 2.1.4 atk >= 1.0.1 pango >= 1.0.1... Requested 'glib-2.0 >= 2.1.4' but version of GLib is 2.0.0


caso você já tenha compilado uma versão acima da 2.1.4..

tenta fazer isso.
[root@Zumbi edson]# whereis pkgconfig
pkgconfig: /usr/lib/pkgconfig /usr/local/lib/pkgconfig


veja foram encontrados duas versões das bibliotecas do pkgconfig.
o /usr/lib/pkgconfig <--aqui vão a bibliotecas instaladas pelos pacotes-devel-XXX.rpm

e os compilados vão para
/usr/local/lib/pkgconfig <-pois eu usei uma compilação default sem --prefix para quando eu precisar remover pacotes compilados e saber exatamente a localização.

Agora localize a glib por exemplo no meu retorna.

[root@Zumbi edson]# whereis glib-2.0
glib-2: /usr/lib/glib-2.0 /usr/include/glib-2.0 /usr/share/glib-2.0



então logicamente será utilizado as configurações presentes em /usr/lib/pkgconfig

tendo estas informações localize a biblioteca glib-2.0.pc..

[root@Zumbi edson]# locate glib-2.0.pc
/usr/lib/pkgconfig/glib-2.0.pc


ela foi localizada em /usr/lib/pkgconfig
se você achar duas versões por exemplo uma em /usr/lib/pkgconfig e outra em /usr/local/lib/pkgconfig
a versão que você compilou se foi feita uma compilação padrão
vai estar localizada no /usr/local/lib/pkgconfig
aí você terá duas alternativas.

1-adicionar a linha /usr/local/lib/pkgconfig ao arquivo /etc/ld.so.conf e depois rodar um ldconfig pra ver se funciona.

2-copiar a versão mais recente da glib-2.0.pc de /usr/local/lib/pkgconfig/glib-2.0.pc para /usr/lib/pkgconfig/glib-2.0.pc
mas antes de fazer isso sugiro que renomeie a outra para caso algo de errado aconteca você só renomea-la novamente para tudo voltar ao normal..pois você pode ter as duas versões por questões de compatibilidade.

ou ainda procura a versão mais recente em RPM para a sua distro pacote-xxx.rpm e os pacotes de desenvolvimento pacote-devel-xxx.rpm.

se tudo correr bem você vai poder ver estas mensagens.
checking for pkg-config... /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... yes (version 2.2.1)
checking for glib-2.0 >= 2.0.0 gobject-2.0 gmodule-2.0... yes
checking DEP_CFLAGS... -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
checking DEP_LIBS... -Wl,--export-dynamic -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0

checking for gtkdoc-mkdb... true
checking gtk-doc version (1.0) >= 0.9... yes
checking whether make is GNU Make... yes
checking for gawk... gawk
checking for perl5... perl5
configure: creating ./config.status
config.status: creating Makefile
config.status: creating po/Makefile.in
config.status: creating atk.pc
config.status: creating atk-uninstalled.pc
config.status: creating atk/Makefile
config.status: creating tests/Makefile
config.status: creating docs/Makefile
config.status: creating atk.spec
config.status: creating atk-zip.sh
config.status: creating config.h
config.status: executing default-1 commands
config.status: executing default-2 commands
FAdrian Fox
FAdrian Fox Membro Junior Registrado
129 Mensagens 0 Curtidas
#4 Por FAdrian Fox
11/04/2003 - 02:08
Xterminator-again
Só ví essa mesagem agora.....
bem você já compilou a glib ?
veja que ele está pedindo uma versão 2.1.4 ou superior....


Pô véio, valeu mesmo a dica. Era o que tava faltando!!!
Agora falta só eu conseguir ver os caracteres especiais das partições windows pra ficar tudo redondinho. Mas isso são cenas dos próximos capítulos!

Um forte abraço!!!
Filipe Lyra
------------------
Celeron D300 2.66 | 4Gb DDR800 | HD 120 + 160 Gb 7200 <-> Win XP
© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal