Logo Hardware.com.br

Instalação, Configuração e Particionamento

Sala destinada para questões, dúvidas e dicas envolvendo instalação e configuração das diversas distribuições Linux e de SOs livres existentes (FreeBSD, Hurd etc). Qual distribuição escolher, utilização das ferramentas de configuração, configuração dos repositórios, instalação de programas e problemas gerais.

1
0

Montando FreeBSD no Linux

bom dia pessoal, instalei o FreeBSD no meu pc, nele tem um linux tbm.
ta em dual boot e o grub do linux ta configurado....
bom vamos ao que interessa, não consigo montar o sistema de arquivos do Free no linux,

mount -t ufs -o ufstype=44bsd /dev/hda1 /freebsd

ele me volta com mensagem de erro (nun lembro agora foi de cabeça)...

no kernel do meu linux, estou procurando mas nao achei nada sobre ufs...

to com um Fedora kernel 2.6... valeu pessoal
0

Configurar GRUB

Pessoal, postei minha duvida em outro forum, mas o pessoal de lá não está muito disposto a me ajudar....espero q aqui eu tenha mais sucesso.

Preciso de um help tb para ajudar a configurar o Grub. Meu caso é o seguinte:

O grub inicia default o Fedora Core2.
Em hda1, tenho uma partição NTFS com WinXP
Em had6, tenho partição / com Mandrake 10
Em hda3, a / do FC2.

Meu arquivo menu.lst está da seguinte forma:
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,2)
# kernel /boot/vmlinuz-version ro root=/dev/hda3
# initrd /boot/initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
title Fedora Core (2.6.5-1.358)
root (hd0,2)
kernel /boot/vmlinuz-2.6.5-1.358 ro root=/dev/hda3 rhgb quiet
initrd /boot/initrd-2.6.5-1.358.img
title Other
rootnoverify (hd0,0)
chainloader +1

Já andei pesquisando no Guia Foca, mas minha ignorancia nao permitiu resolver ainda.
Quais alterações tenho q fazer ?
Agradeço desde já
0

GRUB Loading stage2.Reader Error

não tinha do que reclamar do Cl10 ... ele estava funcionando perfeitamante até que um dia.... mandei reiniciar o Comp. e ele apresentou a seguinte mensagem de erro no boot

GRUB Loading stage2. Reader Error

reinstalei o GRUB , o CL10 e nada.... então dei um fdisk /MBR e instalei tudo denovo WinXP depois o Mandrake 10 mas não instalei o grub na MBR e por ultimo o CL10, tb não instalei o grub na MBR...
até instalar o CL10 o windows iniciava normalmente depois, mesmo pedindo para instalar o grub na particão e não na MBR, ele alterou a MBR... e a mensagem voltou

GRUB Loading stage2. Reader Error

alguem já teve este tipo problema?
0

Num consigo personalizá o Grub.

Tentei mudar o plano de fundo do Grub (andei dando umas lidas no site do cl10, falava que a imagem deveria ser 640x480, 14 cores e no formato *.xpm - foi o que eu fiz - tudo no Gimp) mas quando mudava direitinho o arquivo "/boot/grub/menu.lst" o Grub ficava com a tela toda preta (com os textos em verde). Aguém saberia me dizer o que pode estar errado?

Ah, e queria também saber se dá para personalizar aquele texto que fica logo abaixo das opções do Grub (tá em Inglês, queria colocar em português, e outro texto), tem como?

Bem , é só isso.

Grato à todos.
0

Problema inexplicavel na inicialização.

Fala galera ? beleza ?
Estou com uma dor de cabeça tremenda com o linux aqui na empresa, eu tenho um servidor RedHAT 9, inicalizado por GRUB, partição ext3.
Ele trava logo após sair do GRUB quando fica:

Freeing unused kernel memory: 132k freed
INIT: version 2.84 booting

Ele morre ai, não faz mais nada !! simplesmente nada !!
Já mudei a HD para 3 máquina diferentes de diferentes configurações para ver se era hardware e nada, o problema continua o mesmo !!

Eu preciso disso solucionado extremamente rápido !! Abraços, leandro
0

Ih, num tô conseguindo iniciar o Win98.

Bem, é o seguinte:

Tô com o Conectiva 10 e WinXP em dual boot. Aí fui instalar o Win98SE.
Tá ele sobrescreveu a MBR, logo não conseguia iniciar nem o WinXP, nem o CL10. Aí peguei o CD 1 do CL10 e regravei o Grub.

Beleza, só q agora só consigo iniciar o WinXP ou o CL10.

Alguém poderia me mostrar como é q tá o arquivo /boot/grub/menu.lst?

Tá aí meu menu.lst:

title = Microsoft Windows XP Home Edition
unhide (hd0,0)
rootnoverify (hd0,0)
chainloader +1
makeactive

title = Microsoft Windows 98 Second Edition
unhide (hd0,2)
rootnoverify (hd0,2)
chainloader +1
makeactive


title = Conectiva Linux 10 - Kernel 2.6.5-63077cl
kernel = (hd0,1)/boot/vmlinuz-2.6.5-63077cl root=/dev/hda2 vga=0x314 splash=silent 5
initrd = (hd0,1)/boot/initrd-2.6.5-63077cl

title = Conectiva Linux 10 - Kernel 2.6.9-69538cl
kernel = (hd0,1)/boot/vmlinuz-2.6.9-69538cl root=/dev/hda2 vga=0x314
initrd = (hd0,1)/boot/initrd-2.6.9-69538cl

title = Memory Testing Utility
kernel = (hd0,1)/boot/memtest86


Ob.: Essa opção do Win98 fiz de acordo com a opção do WinXP, mas quando seleciono no Grub p/ iniciar o 98, ele simplesmente não inicia, apesar do indicador de funcionamento do hd tá aceso.

Grato à todos.
0

GRUB pelo diskette soh inicia sem HD!!?

Estou com o SUSE Linux 9.1 instalado aqui, mas no hdd1. Fiz a instalacao sem os outros HD ligados na mobo. Ao final optei por criar um disco de boot pois nao queria o GRUB na MBR do hda ainda. O diskette boota ok.

Qdo plugo os outros HDs na maquina (hda e hdb) o diskette nao funciona mais! O q pode ser? Ele pára com a mensagem "GRUB" na tela, soh isso, e se fico teclando o PC fcia dando aqueles 'bips'... Se desplugo os hds da IDE primaria, deixando apenas o hd com o SUSE e CD ROM ae sim o diskette dah o boot...

O q tah acontecendo? Jah tinha usado o GRUB uma vez antes mas acho q tenho muita coisa a aprender ainda, afinal sempre usei o LILO. Como fazer o diskette bootar o hdd1 com os outros HDs presentes?
0

Problemas com o Eclipse

Pessoal, quando tento rodar o eclipse está dando os seguintes erros (obviamente estou com a J2SDK configurada corretamente e funcionando, bem o como o CLASSPATH).


carlos@prj-03:~$ eclipse
Unable to restore editor - createElement returned null for input element factory: org.eclipse.ui.internal.dialogs.WelcomeEditorInputFactory
Could not create view: 'org.eclipse.ui.views.ProblemView'.
Unable to find Action Set: org.eclipse.help.ide.HelpSearchActionSet
Unable to find Action Set: org.eclipse.ui.edit.text.actionSet.openExternalFile
java.lang.IllegalArgumentException: Argument not valid
at org.eclipse.swt.SWT.error(SWT.java:2316)
at org.eclipse.swt.SWT.error(SWT.java:2260)
at org.eclipse.swt.graphics.GC.drawImage(GC.java:378)
at org.eclipse.swt.graphics.GC.drawImage(GC.java:361)
at org.eclipse.swt.custom.CTabFolder.scaleImage(CTabFolder.java:1761)
at org.eclipse.swt.custom.CTabFolder.updateArrowBar(CTabFolder.java:1884)
at org.eclipse.swt.custom.CTabFolder.setButtonBounds(CTabFolder.java:970)
at org.eclipse.swt.custom.CTabFolder.setItemLocation(CTabFolder.java:1045)
at org.eclipse.swt.custom.CTabFolder.setItemBounds(CTabFolder.java:1128)
at org.eclipse.swt.custom.CTabFolder.onResize(CTabFolder.java:1309)
at org.eclipse.swt.custom.CTabFolder.access$2(CTabFolder.java:1302)
at org.eclipse.swt.custom.CTabFolder$1.handleEvent(CTabFolder.java:199)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:81)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:923)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:948)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:932)
at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:803)
at org.eclipse.swt.custom.CTabFolder.resetTabSize(CTabFolder.java:2148)
at org.eclipse.swt.custom.CTabFolder.createItem(CTabFolder.java:386)
at org.eclipse.swt.custom.CTabItem.(CTabItem.java:100)
at org.eclipse.ui.internal.PartTabFolder.createPartTab(PartTabFolder.java:247)
at org.eclipse.ui.internal.PartTabFolder.createControl(PartTabFolder.java:224)
at org.eclipse.ui.internal.PartSashContainer.createControl(PartSashContainer.java:192)
at org.eclipse.ui.internal.PerspectivePresentation.activate(PerspectivePresentation.java:96)
at org.eclipse.ui.internal.Perspective.onActivate(Perspective.java:725)
at org.eclipse.ui.internal.WorkbenchPage.onActivate(WorkbenchPage.java:1799)
at org.eclipse.ui.internal.WorkbenchWindow$7.run(WorkbenchWindow.java:1496)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
at org.eclipse.ui.internal.WorkbenchWindow.setActivePage(WorkbenchWindow.java:1483)
at org.eclipse.ui.internal.WorkbenchWindow.busyOpenPage(WorkbenchWindow.java:416)
at org.eclipse.ui.internal.WorkbenchWindow$6.run(WorkbenchWindow.java:1188)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
at org.eclipse.ui.internal.WorkbenchWindow.openPage(WorkbenchWindow.java:1185)
at org.eclipse.ui.internal.Workbench.openFirstTimeWindow(Workbench.java:1074)
at org.eclipse.ui.internal.Workbench.init(Workbench.java:874)
at org.eclipse.ui.internal.Workbench.run(Workbench.java:1373)
at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:858)
at org.eclipse.core.boot.BootLoader.run(BootLoader.java:461)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.basicRun(Main.java:291)
at org.eclipse.core.launcher.Main.run(Main.java:747)
at org.eclipse.core.launcher.Main.main(Main.java:583)
carlos@prj-03:~$

Alguém sabe o que pode ser?
© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal