Logo Hardware.com.br

Instalação, Configuração e Particionamento

Sala destinada para questões, dúvidas e dicas envolvendo instalação e configuração das diversas distribuições Linux e de SOs livres existentes (FreeBSD, Hurd etc). Qual distribuição escolher, utilização das ferramentas de configuração, configuração dos repositórios, instalação de programas e problemas gerais.

1
0

Synaptic Software Manager do PCLinuxOS falha a ligação

Bom dia.
Eu sou iniciante em Linux e estou a ter alguns problemas em migrar para este sistema. O principal é o de não conseguir conectar-me à internet (e às vezes quando conseguia, e internet andava muito devagar) em todas a distribuições.
Depois de experimentar várias ditros - -incluindo a tão divulgada aki (Kurumin), onde também tive problemas com a internet - - estou agora a usar a PCLinuxOS. Com este sistema tenho a internet e rede a funcionar, mas quando vou procurar mais aplicações, o Synaptic Software Manager falha sempre na ligação.
Já tentei instalar programas descarregados manualmente através da linha de comandos, mas surge sempre alguma incompatibilidade.
Como é dificil encontrar aplicações expecificas para esta distro e como o PCLinuxOS vem com muito poucas aplicações, era importante que o Synaptic Software Manager funcionasse.

Aproveito para deixar algumas questões com as quais estou a ter dificuldade em encontrar uma resposta:
* Porque é que as aplicações de Linux não funciona em todas as distribuições?
* Porque será que a minha internet funciona em algumas distros e em outras não? (penso que tinha as configurações bem feitas)
* Existe alguma tradução do PCLinuxOs para português?
* Como instalo rpm's descarregados manualmente sem ser pela linha de comandos?
* Como instalo, nesta distro, pacotes .deb? Dão para instalar aqui?

Deixo também algumas caracteristicas do meu pc (espero que ajude):
* É um portátil HP Pavillion dv 1452 ea;
* Placa de rede: RTL-8139 da Realtek Semiconductor;
* Processador: Intel(R) Pentium(R) M processor 1.73GHz;
* Com 1024 de memória RAM;
* Está ligado a um modem-router NTech;
* Tenho uma ligação ADSL de 4MB do Sapo (Portugal);

Agradeço desde já a atenção e espero por alguma ajuda,

Vítor Hugo Silva
0

Ao rodar o winecfg zoa o LILO

Instalei o Wine (tentei tanto o do proprio site do winehq quanto do linuxpackages) e, desde versões bem antigas, toda vez que rodo o winecfg pra configurá-lo, quando reinicio o micro, o lilo para no L.
Aí sou obrigado a dar boot pelo disquete e rodar o comando lilo -b /dev/hdb1 (onde fica o Slack).

Acontece com mais alguém? o que pode ser? será que é quando ele determina as partições pra usar como a do windows? mas por que mexer no mbr?
0

como não perder o grub ao instalar o win?

olá! tipo, geralmente, um problema bem comum que se tem, é as pessoas quererem recolocar o boot-loader do xp, e tirar o grub, ou lilo, mas, todos sabem que o melhor é instalar primeiro o win e depois o linux, para não dar probelmas de perder o grub... então, eu fui obrigado instalar o li primeiro, e agora que vou instalar o win, me lmbrei dess eprobelam... daí, será que tem alguma forma de manter preso o frub, impedir o boorlodaer do xp, ou recuperar o grub???

parece estranho, mas, eu não quero tirar o grub :lol:

ah, to com o ubuntu...
0

Como restaurar o LILO no SuSe 10.1?

Eu tava com o win xp pro sp2 instalado e redimensionei o espaco do hd e criei mais uma particao..pois bem, instalei o SuSe 10.1 e ate ae ta d boa...mostra o lilo pra escolher qual SO vou usar...mas ae formatei o C: onde o win tava instalado e reinstalei ele tbm...pra zerar a maquina. ae fiz cagada..hehehe...agora eu acho que apaguei akele setor do MBR onde fica gravado as informacoes do LILO..como q eu faço pra restaurar especificamente no suse 10?
0

ataulizei o kernel mas o lilo nao da boot no windows

depois que configurei o novo kernel 2.16.20-slh-up-1(isso foi feito pois mjeu mouse otico n-ao funcionava no kernel antigo do kurumin 6) configuei o lilo para dar boot pelo kernel novo tudo funcionou legal mas na hora do boot do winXp ele atpresenta um erro de auxencia de arquivo ntlr (eu acho que é isso), outra coisa alguem sabe como configurar um modem da LG Samrt Link Voice 56 e um outro problema que nao sei como solucionar no Kurumin.
0

Pergunta"GNU GRUB Version 0.97"como tirar as atual

Sou novo na comunidade e iniciante em Linux gostaria de saber como faço para poder tirar "GNU GRUB Version 0.97" as atualizações deixando apenas uma para eu poder acessar??

Fedora Core (2.6.16-1.2133_Fc 5 smp)
// (2.6.16-1.2133_Fc 5)
// (2.6.15-1.2054_Fc 5)

Como eu faço para eliminar 2 dessas atualizações ???

Desde já agradeço.
0

Acessar Fedora utilizando o lilo.conf do Kurumim.

Boa noite pessoal !!

Sou novo no forum e gostaria da ajuda de vocês para incluir o Fedora Core na lilo.conf do Kurumim-6.0.
Já uso há dois anos o Kurumim e gostaria de estar testando outras distro e escolhí o Fedora pra tal.
Possuo dois HDs que estão assim distribuidos:

HDA Primario - SAMSUNG SP8004H
- Partição 1* - /dev/hda1 (20Gb) - Filesystem = NTFS (WindowsXP)
- Partição 2 - /dev/hda2 (35Gb) - Filesystem = Fat32 (uso Win/Lin)
- Partição 4 - /dev/hda4 (20Gb) - Filesystem = Fat32 (uso Win/Lin)

HDB Secundario - SAMSUNG SP0802N
- Partição 1 - /dev/hdb1 (55Gb) - Filesystem = ReiserFS (uso Lin - Home)
- Partição 2 - /dev/hdb2 (10Gb) - Filesystem = Extended 3 (Fedora Core)
- Partição 3* - /dev/hdb3 ( 8Gb) - Filesystem = ReiserFS (Kurumim 6.0)
- Partição Swap /dev/hdb4 ( 2GB) - Filesystem = Memory Swap
*=MBR

Pois bem, inicialmente instalei o Kurumin (hdb3) e configurei o Home em separado (hdb1) para utiliza-lo também pelo Fedora (hdb2).
Instalei o Fedora (hdb2) com opção de inicializar outros sistemas (Win e Kurumim) porém, não me atentei que no instalador há a opção de selecionar em qual HD irá gravar a MBR e gravei na HDA.
Após a instalação, reiniciei o sistema e ... tela preta e GRUB. Uso o lilo porque não sei usar o Grub. oops.png
Conclusão: Não acessei nenhum dos três sistemas, mesmo alterando a seqüencia de inicialização na Bios.
Reinstalei o Kurumim e ele "recuperou" a MBR da HDA e voltei a ter os dois sistemas anteriores ( esse Kurumim é 10 !! :P).
Reinstalei também o Fedora sem a opção de inicializar outros sistemas no hdb2.
O problema é que mesmo constando no lilo.conf o Fedora, quando seleciono para iniciar o mesmo no Menu de Inicialização do Kurumim, o sistema não inicia. Será que é alguma coisa na montagem do dispositivo hdb2 na lilo que impede de montar a partição?
Alguem sabe se é possível alterar de lilo na hdb3 para Grub na hdb2 ?
Não me importo de usar outro gerenciador de inicialização desde que funcione os três sistemas.
Abaixo estão meu lilo.conf (retirei as linhas comentadas para não ficar muito grande o fórum) e o fstab para que vocês possam analisar e me ajudar se possível:

#lilo.conf

boot=/dev/hdb
ignore-table
bitmap = /boot/kurumin.bmp
bmp-colors = 9,255,;255,9,
bmp-table = 61,15,1,12
bmp-timer = 73,29,255,9

vga=788

prompt
compact
default=Kurumin

timeout=100

append = "splash=silent nomce quiet apm=power-off "

image=/boot/vmlinuz-2.6.14-kanotix-6
label=Kurumin
root=/dev/hdb3
read-only
initrd=/boot/initrd-ksplash

other=/dev/hda1
label="WindowsXP"
other=/dev/hda1
label="FedoraCore"

#fstab
# /etc/fstab: filesystem table.
#
# filesystem mountpoint type options dump pass

# 3a. Partição do 2o. HD - Kurumim (Linux)
/dev/hdb3 / reiserfs noatime,notail 0 1

# 4a. Partição do 2o. HD - Swap
/dev/hdb4 none swap sw 0 0

proc /proc proc defaults 0 0
/dev/fd0 /floppy vfat defaults,user,noauto,showexec,umask=022 0 0
# Combo CD-RW - SAMSUNG
/dev/cdrom /mnt/cdrom iso9660 defaults,ro,user,noexec,noauto 0 0
# Combo DVD-RW - LG
/dev/cdrom1 /mnt/cdrom1 iso9660 defaults,ro,user,noexec,noauto 0 0

# partições encontradas pelo instalador:
# 1a. partição do 1o. HD - Windows em 'C:' (MBR)
/dev/hda1 /mnt/hda1 ntfs noauto,users,exec,ro,umask=000 0 0

# 2a. Partição do 1o. HD - 'D:'
/dev/hda2 /mnt/hda2 vfat noauto,users,exec,umask=000 0 0

# 3a. Partição do 1o. HD - 'E:'
/dev/hda4 /mnt/hda4 vfat noauto,users,exec,umask=000 0 0

# 1a. partição do 2o. HD - Home (Linux) (MBR)
/dev/hdb1 /mnt/hdb1 reiserfs noauto,users,exec 0 0

# 2a. partição do 2o. HD - Fedora Core (Linux)
/dev/hdb2 /mnt/hdb2 ext3 noauto,users,exec 0 0

# Monta a partição /home, adicionado pelo instalador do Kurumin
/dev/hdb1 /home reiserfs notail 0 2

# Ativa o sistema de arquivos sys usado pelo Kernel 2.6
sys /sys sysfs defaults 0 0
# Ativa o devpts
none /dev/pts devpts mode=0622 0 0


Muito obrigado big_green.png
0

Meu lilo nao funfa :\

Eu peguei a versao do kurumin 6, copie pro cd
e começei a instalar no meu pc
eu tenho um hd de 40gb no qual esta instalado o windows xp
e tenho um outro hd de 4gb slave, que usei para instalar o linux
usei 1024 para a partição linux-swap e o resto para partição linux padrão!
Na hora da tela do lilo eu a deixei assim.

# Este é o arquivo de configuração do Lilo que será instalado, você pode 
# verificar o arquivo e descomentar as linhas que permitem configurar o
# dual boot com o Windows e outros sistemas operacionais.
# Depois de terminar basta salvar o arquivo e fechar este janela.

# Se você não quer fazer nenhuma alteração simplesmente feche esta janela
# para continuar a instalação. Todas as linhas iniciadas com"#" são
# comentários, que não possuem efeito algum sobre o sistema. Para ativar
# qualquer opção você precisa remover o"#".

# A opção abaixo indica aonde o lilo será instalado, normalmente você não
# precisa se preocupar com ela:

boot=/dev/hdb
ignore-table
bitmap = /boot/Kurumin.bmp
bmp-colors = 9,255,;255,9,
bmp-table = 61,15,1,12
bmp-timer = 73,29,255,9


# RESOLUÇÃO do VÍDEO

# Aqui vai o código que determina a resolução do vídeo, caso o Linux
# tenha configurado seu vídeo usando frame buffer (ou caso você tenha
# usado as opções fb800x600 ou fb1024x768 na tela de boot)

# O default desta opção é"vga=788", que fará o sistema usar resolução
# de 800x600, que é compatível com quase todas as placas de vídeo.
# Se é isso mesmo que você quer utilizar então já está tudo ok. Caso
# você queira mudar a resolução para 1024, então mude a opção para
#"vga=791". Lembre-se que nem todas as placas de vídeo suportam este
# modo, o que faz aparecer uma mensgem de erro no início do boot,
# dizendo que o modo de vídeo não é suportado e pedindo para você
# pressionar Enter duas vezes. Nestes casos você pode testar uma
# resolução mais baixa:

# Se você quer usar resolução de 1024x768, mude a opção para: vga=791
# Se você quer usar resolução de 640x480, mude a opção para: vga=785
# Se a sua placa de vídeo não suporta frame-buffer e você quer de
# volta a velha tela de texto padrão, mude a opção para: vga=normal

vga=791

# OBS: Se você tem uma placa GeForce 4 ou GeForce 4 MX, deixe esta
# opção em"788"

prompt
compact
default=Kurumin

# Tempo de espera antes de entrar no sistema padrão, em décimos de
# segundo (o padrão é 10 segundos). O valor máximo é 30000 (3.000
# segundos), não use um número maior que isto:

timeout=100

# Aqui vão os parâmetros do Kernel. Se você deseja desativar o
# suporte a acpi, para solucionar problemas, adicione a opção
#"acpi=off".
# O disable_timer_pin_1 é necessario em várias máquinas AMD 64
# com chipset ATI.

append ="splash=silent nomce quiet apm=power-off "

# Não altere as linhas abaixo!

image=/boot/vmlinuz-2.6.14-kanotix-6
label=Kurumin
root=/dev/hdb2
read-only
initrd=/boot/initrd-ksplash
# append="splash=silent"


# As linhas abaixo habilitam o memtest86. Este programa faz um
# teste extensivo na memória RAM, identificando defeitos que possam
# comprometer a estabilidade do micro. É aconselhável rodar o teste
# completo (demora várias horas, deixe para deixar o micro rodando
# quando for dormir) depois de instalar o Kurumin.
# Você pode configurar o sistema para ignorar endereços defeituosos
# indicados pelo teste usando a opção"badram=" dentro da linha
#"append", como explicado acima.

image=/boot/memtest86.bin
label=memtest86
root=/dev/hdb5
read-only


# As linhas abaixo oferecem a opção de inicializar outros sistemas
# operacionais instalados no HD. Elas foram adicionadas
# automaticamente pelo genliloconf.
# Edite-as caso necessário, ou caso prefira desabilitar as opções.
#
# Estas opções seguem uma intaxe simples, onde cada entrada contém
# duas linhas.
# A opção"other=" indica a partição onde o outro sistema está
# instalado, como em: other=/dev/hda2
# A opção"label" indica o nome da opção, que aparece no menu de
# boot.
# Uma observação importante: Os nomes não podem ter mais de 14
# caracteres e não podem conter espaços ou caracteres especiais.
# Isto é importante, pois ao adicionar um nome inválido aqui o
# lilo não será corretamente instalado e seu micro pode não dar
# boot após a instalação.
#
# Um exemplo de entrada válida seria:
# other=/dev/hda2
# label=Windows

other=/dev/hda1
label=Windows(hda1)
other=/dev/hdb2
label=Kurumin


# Windows instalado no segundo HD:
# Esta é uma opção especial que permite que você inicialize uma
# instalação do Windows no segundo HD (instalado como slave do
# primeiro, onde está o Kurumin).
# Ela faz o Windows pensar que está sendo inicializado do primeiro
# HD
# Descomente todas as sete linhas abaixo, altere o"hdb1" por
#"hdc1" ou"hdd1" caso o HD esteja instalado na segunda IDE.
# Lembre-se:
# Primeira IDE : Master = hda / Slave = hdb
# Segunda IDE : Master = hdc / Slave = hdd

#other=/dev/hdb1
#label=Windows3
#table=/dev/hdb
#map-drive = 0x80
#to = 0x81
#map-drive = 0x81
#to = 0x80

# Parabéns, você acaba de aprender que configurar o lilo não é
# tão difícil quando parece

# Se você está dentro do programa de instalação do Kurumin
# simplesmente salve o arquivo e freche esta janela para que o
# lilo seja finalmente gravado.

# Se você está alterando este arquivo fora do programa de
# instalação, abra o root shell encontrado em Iniciar >
# Configuração do sistema e digite"lilo" na linha de comando
# para salvar as alterações.


O que estou fazendo de errado?

Grato!
0

Recuperando o GRUB

Pessoal...

Tenho o XP1 no HD master, e no HD slave, tenho o linux Debian Sarge instalado. O boot é gerenciado pelo GRUB (que fica alocado no HD master). Pretendo instalar o XP2 por cima do XP1 no HD master, e com isso, acredito q eu vá perder o GRUB.

Tenho estas perguntas:

1 - Se eu instalar o XP2 por cima do XP1, realmente perderei o GRUB?

2 - Se eu perder o GRUB, tenho como instalar outro GRUB que gerencie o boot como o que foi apagado? Ou seja:
HD master = windows XP2 e
HD slave = Debian Sarge

Supondo que algo dê errado na instalação do XP2 no HD master, pretendo retirar o HD master do PC e jumpear o slave como master.

3 - Feito isso, o boot se dará normalmente pelo Debian Sarge como se ele sempre tivesse sido o único sistema operacional do PC, ou simplesmente não haverá boot em função de algum tipo de referência que ficou na unidade C: (HD master)?

4 - Se não acontecer o boot de acordo com a pergunta acima, será possível dar boot neste HD e carregar o Debian através diskete de boot com GRUB, lilo ou outro recurso?

Obrigado,

Icarus
0

"Trial Boot" Kurumin6.0+XP+W98SE e HD SATA

Quando usava somente dois HD´s IDE conseguia inicializar beleza o Kurumin 6.0 (instalado em 1 HD IDE com XPSP2 e Win98SE em outro)através do "Trial Boot" com o Lilo. Depois que substitui o IDE dos Windows por um SATA, nao consigo mais configurar o Lilo para o "Trial Boot", ficando apenas o "Dual Boot" (XP + Win98SE). Pelo Kurumin (acessado via CD), o SATA e o dispositivo "sda" o IDE "hda" na config. do Lilo so substitui o que existia por estes dispositivos, porem na tentativa de gravacao ocorre diversos erros e obviamente nao carrega o gerenciador do boot. Alguem pode ajudar em algo?
0

Nao consigo configurar o meu kurumin para dar boot no lilo

Pessoal, sou hiper novo no forum e gostaria de uma ajuda. Instalei ontem o kurumin 5.1 beta no meu micro pela primeira vezjunto com o winxp, so que eu gostaria que o lilo desse boot primeiro no winxp e nao no kurumin. Eu queria q a primeira opcao q aparecesse fosse a do winxp. Alguem poderia me ajudar?


MICRO: Celeron D 2.53GHZ, hd 40gb, 512MB, toda onboard, gravador de cd.
0

Grub não reconhece hda e não inicia o windows me

Olá, pessoal. Um grande abraço para todos.

Tenho uma HD scuzzi (/dev/sda ==> hd0)onde instalei o FC4 primeiramente. Em seguida, instalei outra HD Sansumg de 40GB (/dev/hda) e coloquei nela o Windows ME. Para poder iniciar por um ou outro sist. operacional, instalei o Grub na sda e estou tentando fazer com que ele enxergue o Windows ME para inicia-lo, mas o Grub inicia com as duas possibilidades, mostra a opção windows (conforme inseri no boot/grub/menu.lst), mas quando escolho a opção windows ele dá mensagem de erro:

ERROR 13: Invalid ou unsupported executable format

Já chamei de hd1, hd2, hd0 e nada.

Tentei também instalar o grub na hda, mas o comando
#install-grub /dev/hda
dá a mensagem:

"/dev/hda does not have any corresponding BIOS drive."

Enfim, tudo o que desejo é o boot dual funcionando. Se alguém puder me auxiliar a encontrar uma solução, desde já agradeço.
© 1999-2024 Hardware.com.br. Todos os direitos reservados.
Imagem do Modal